Attivazione della licenza
 Top Next
Al primo utilizzo del programma si deve registrarlo per ottenere la licenza d’uso e apparirà questa videata.

Dovrete comunicare al distributore del programma il vostro indirizzo mail e il codice che viene proposto in alto (si tratta del codice seriale del vostro hard disk).

Nel giro di un paio di giorni, al massimo, vi verrà comunicato il codice di attivazione da inserire insieme all’indirizzo mail comunicato nelle apposite caselle.

Nelle caselle sono ammessi solo caratteri maiuscoli per ridurre al minimo le possibilità di errori di inserimento.

Se tutto è stato riportato correttamente il programma si avvierà


Avvertenze
 Previous Top Next
Un avviso importantissimo che ritengo doveroso esporre.

Questo programma non deve essere inteso assolutamente come istigazione al gioco.
Sappiate che per il giocatore l’unica certezza è quella di buttare i soldini impiegati per le giocate.

Il sottoscritto ed il distributore del software non potranno essere ritenuti responsabili di eventuali perdite di denaro o qualsiasi altro danno diretto o indiretto dovuto dall’utilizzo del software.

La legge n.111, art.24, commi 19-22 del 15/07/2011 disciplina il divieto di partecipazione ai giochi con vincite in denaro per i minori

Le previsioni proposte dal sotware devono essere considerate come esperimenti, come un divertimento, ma senza giocare realmente, o se giocate investite cifre minime per non avere delusioni e perdite economiche.

In tanti anni dedicati allo studio del lotto ho avuto occasione di informatizzare moltissimi metodi di numerosi studiosi, venduti anche a caro prezzo, e, credetemi; non ne ho trovato nessuno che abbia fornito vincite continuative e certe. Quindi ATTENZIONE !!!!!!

A questo punto buona fortuna a tutti voi con l’utilizzo di questo software.


Avvertenze per la selezione dell'archivio
NOTA PER LA SELEZIONE DELL’ARCHIVIO DELLE ESTRAZIONI:

Il pulsante SELEZIONA ARCHIVIO presente nella videata iniziale, deve essere utilizzato solamente al primo utilizzo del software.

Non serve per aggiornare l’archivio.

Per l’aggiornamento si deve utilizzare l’apposito modulo.

È necessario leggere le istruzioni per procedere nel modo corretto.

L’help in linea si visualizza premendo il tasto F1 sulla tastiera del PC oppure, se presenti, tramite i pulsantini dedicati.

Se utilizzate un portatile, probabilmente dovrete premere prima il tasto FN (dovrebbe essere in basso a sinistra) e mentre tenete premuto questo tasto, premere F1.


Selezione archivio estrazioni
L’archivio delle estrazioni risiede in un database Access con estensione Mdb.

Potrete disporre di altri miei software che possono utilizzare un unico archivio per cui, al primo utilizzo del software viene richiesto a quale archivio fare riferimento per poterne aggiornare uno solamente che poi sarà utilizzato anche da altri software.

Per selezionare l’archivio, quando comparirà questa videata…

Premere il pulsante SELEZIONE ARCHIVIO

Ricercare l’archivio da utilizzare (viene sempre proposto quello contenuto nella cartella di installazione del software)

Selezionare il file, in questo caso DbTriplaSommaTop, e premere il pulsante Apri.

Nb: Se selezionerete un altro archivio, il nome sarà diverso.

L’archivio è selezionato e la videata sarà chiusa.

Nella precedente videata viene aggiornata la posizione dell’archivio (sotto la scritta Percorso archivio)

Attenzione: al primo lancio del programma il percorso sarà sicuramente errato in quanto è quello riferito al mio PC.
Quindi se procederete senza la necessaria configurazione il programma terminerà in quanto il file di riferimento non sarà trovato. Normalmente il programma apre in automatico la finestra per la selezione dell’archivio.

Una volta configurato l’archivio premere il pulsante PROCEDI per visualizzare la videata contenitore del software.

Avvertenza:

In alcuni casi il database fornito con il programma potrebbe essere replicato nella cartella Virtualstore del PC per cui il percorso potrebbe essere ad esempio:

C:\Users\User\AppData\Local|VirtualStore\Program Files (x86)\TriplaSommTop

Dove User potrebbe essere sostituito dal vostro account .

La cartella AppData potrebbe essere nascosta per cui per visualizzarla dovete modificare le proprietà di visualizzazione (lo si può fare dal pannello di controllo).


Generalita

Generalità

Dopo aver utilizzato il pulsante PROCEDI nella sezione iniziale appare questa interfaccia dove si può selezionare il modulo per la gestione dell’archivio (il 1° pulsante con il raccoglitore) oppure il modulo della tripla somma top (il pulsante con tre puntini neri su sfondo bianco). Quest’ultimo modulo si aprirà automaticamente. Nella parte destra è presente il pulsante per la chiusura del programma. Nella parte sinistra abbiamo anche i riferimenti relativi alla prima rd ultima estrazione presente nell’archivio utilizzato

Questa è la videata che appare al lancio del programma.

La tabella principale è vuota in quanto non sono ancora state effettuate elaborazioni.

Vediamo gli oggetti che abbiamo a disposizione e come utilizzarli.

Questa è la barra che consente di selezionare l’estrazione di riferimento. L’elaborazione procederà a ritroso sino al raggiungimento del numero delle casistiche impostato.

Le tre icone in alto consentono una selezione rapida delle estrazioni in base alla data, al numero dell’estrazione e all’ultima estrazione in archivio.

Il check Fine ricerca consente di bloccare la verifica delle previsioni all’estrazione selezionata quando questa è antecedente alla fine dell’archivio.

Il check Ultima imposta forzatamente l’estrazione finale dell’archivio come ultima del mese.
Questo può servire quando la data dell’ultima estrazione in archivio non consente di stabilire se è l’ultima del mese.

La casella in alto a sinistra oltre a specificare il numero e la data dell’estrazione di riferimento, riporta anche il progressivo mensile

Le ruote su cui devono rilevarsi determinate condizioni si selezionano in questa sezione. Tutte le successive selezioni sono sempre subordinate alla selezione complessiva delle ruote (quelle evidenziate in giallo).

Qui sono descritte le funzionalità dei check box presenti.
Check | Spiegazione
Tutte | Sono considerate tutte le ruote tra quelle selezionate. La selezione di questa opzione rende inutili tutte le altre scelte.
Diametrali | Vengono considerate le sole ruote diametrali
Adiacenti | Sono considerate le ruote adiacenti (anche bari e Venezia fanno parte di questa scelta)
Gemelle | Sono considerate le ruote gemelle
GMTV | Sono le ruote estratte nella sede del nord (Genova, Milano, Torino, Venezia)
CFRZ | Sono le ruote estratte nella sede del centro (Cagliari, Firenze, Roma, Nazionale)
BNP | Sono le ruote estratte nella sede del sud (Bari, Napoli, Palermo)

Nelle ultime tre selezioni non viene presa in considerazione la ruota Nazionale.

Ecco per chiarezza l’elenco di riferimento

Ruote diametrali:
R1 | R2
Bari | Napoli
Cagliari | Palermo
Firenze | Roma
Genova | Torino
Milano | Venezia

Ruote gemelle:
R1 | R2
Bari | Venezia
Cagliari | Torino
Firenze | Roma
Genova | Palermo
Milano | Napoli

Ruote adiacenti:
R1 | R2
Bari | Cagliari
Cagliari | Firenze
Firenze | Genova
Genova | Milano
Milano | Napoli
Napoli | Palermo
Palermo | Roma
Roma | Torino
Torino | Venezia
Venezia | Bari

I due ultimi pulsantini a fianco (verde e bianco) consentono la selezione o deselezione di tutte le ruote.

Qui si abilitano le posizioni dove devono essere presenti i numeri rilevati. Considerate che la ricerca tipica prevede la considerazione delle posizioni isotope (quella preselezionata)

Con la prima riga si determinano le posizioni della prima ruota.
Nella seconda riga si selezionano le posizioni consentite per la seconda ruota.
Check | Spiegazione
Iso | Sono considerate solamente le posizioni isotope. I numeri devono essere estratti nelle stesse posizioni.
1 | Almeno due numeri devono occupare la stessa posizione (uno per ruota)
Adi | Sono ammesse le sole posizioni adiacenti (1-2, 2-3, 3-4, 4-5, 5-1)

I pulsantini a fianco (verde e bianco) consentono la selezione o deselezione di tutte le posizioni delle due righe

Oggetto | Spiegazione
N° Casi | Quanti casi ricercare. Sovente i casi effettivamente rilevati saranno maggiori del valore impostato. Questo perché il software termina sempre tutte le casistiche associate ad una stessa estrazione.
Mensile | Una determinata estrazione mensile. La selezione è presa in considerazione solamente se il check a fianco è selezionato.
Check | Posto a fianco della lista Mensile. Se abilitato saranno considerate solo le estrazioni in cui il progressivo mensile è quello selezionato. Se il check è deselezionato sono considerate tutte le estrazioni.
Ambata | La modalità operativa da applicare all’ambata originaria
Fisso | Un valore fisso da sommare all’ambata di partenza
Passo | Il valore che intercorre tra i numeri della lunghetta. Attenzione: la selezione di alcuni valori potrebbe generare numeri identici nella lunghetta. In questi casi il numero dei numeri che formano la lunghetta sarà inferiore anche se vengono riportati anche i valori ripetuti.
Colpi | I colpi di gioco della previsione

Le selezioni all’ambata sono:
Selezione | Ambata generata
Originale | È considerata l’ambata originale (la somma dei 3 numeri con la stessa caratteristica di rilievo)
Vertibile | Viene calcolato il vertibile dell’ambata originale
Complemento 91 | Viene calcolato il complemento a 91 dell’ambata di origine
Diametrale | Viene calcolato il diametrale dell’ambata di origine
Diametrale in decina | Viene calcolato il diametrale in decine dell’ambata originale
Triplo sommativo | Viene considerato il triplo sommativo

Note relative al passo.

Come accennato un utilizzo di valori improprio può generare ripetizioni di numeri nella lunghetta.

I numeri della lunghetta sono generati impostando come primo elemento l’ambata generata. Supponiamo che sia 25.

Se selezioniamo una lunghetta formata da 6 elementi ….

25 sarà il primo elemento
25+30=55 il secondo elemento
55+30=85 il terzo elemento
85+30=25 il quarto elemento (che è identico al 1° numero)
25+30=55 il quinto elemento (che è identico al 2° numero)
55+30=85 il sesto elemento (che è identico al 3° numero)

È evidente che è inutile scegliere una lunghetta di 4, 5, 6 o 7 numeri per queste situazioni in quanto la selezione giusta potrà essere di soli 3 numeri.

Basterà ragionare un attimino prima di selezionare il valore da utilizzare come passo della lunghetta.

La prima grid (Numeri) consente di selezionare i numeri da considerare per le ricerche.
Cliccando in una qualsiasi cella la possiamo selezionare o deselezionare.

L’altra grid (Somme) consente di selezionare le somme generate dai tre numeri che rispondono alla condizione di rilevazione (descritta più avanti).
Cliccando in una qualsiasi cella la possiamo selezionare o deselezionare.

I pulsantini verdi e bianchi a fianco di queste grid consentono una selezione completa o la deselezione completa.

Qui si decide la caratteristica che devono rispettare i numeri rilevati.

Questa caratteristica prevede che 3 e solo 3 numeri tra i 4 considerati (2 per ruota) devono appartenere alla stessa decina, o alla stessa cadenza o alla stessa figura. Non sono ammessi numeri uguali.

Nel caso in cui si selezionano più valori (esempio decina 3, 4 , 5…) sono considerati tutti i casi in cui tre dei 4 numeri appartengono alla decina 3, 4 o 5.

Possiamo lavorare con decine, cadenze o figure.

Nell’ambito di una delle 3 possibilità possiamo selezionare più valori.

La selezione dei valori abilitati, come al solito, si ottiene cliccando nelle celle corrispondenti. Noterete che a secondo della riga viene anche evidenziata la formazione corrispondente in verde (questa sarà quella considerata nell’elaborazione).

I pulsantini a fianco consentono di:

Il pulsantino giallo selezionerà tutti i valori della riga con la selezione verde
Il pulsantino bianco deselezionerà tutti i valori della riga con la selezione verde
Il pulsantino blu selezionerà tutti i numeri appartenenti alle formazioni scelte nella riga con la selezione verde.

I numeri posti sotto la scritta Lunghetta consentono di selezionare il quantitativo di numeri della lunghetta.

Il pulsante RICAVA BASE DATI consente i ricavare le casistiche rispondenti alle selezioni effettuate.

Il pulsantino col quadratino rosso consente l’interruzione delle elaborazioni qualora, caso raro, il tempo andasse per le lunghe. Dopo la pressione di questo comando potrebbero passare pochi secondi prima dell’effettiva interruzione dell’elaborazione. Vi raccomando sempre di attendere la fine delle elaborazioni prima di utilizzare altri oggetti della videata. Se non impostate configurazioni estremamente anomale difficilmente dovrete ricorrere all’interruzione delle elaborazioni.

Il check ambata abilita le previsioni di ambata
Il check Lunghetta abilita le previsioni della lunghetta

La mancata selezione di almeno uno dei due check produce una elaborazione nulla.

Il pulsante PREVISIONI ricaverà le previsioni in base alla base dati rilevata.
Nella casella gialla saranno visualizzate il numero di casistiche rilevate
Gli ultimi due pulsantini servono per la stampa o la copia dei dati presenti nella tabella principale.


Effettuare una elaborazione
RICAVIAMO LA BASE DATI.

Utilizzando l’omonimo comando questa è una situazione tipica che si può presentare

Cliccando sul pulsante PREVISIONI ecco cosa succede

Vediamo di descrivere i dati che si sono generati:

Per prima cosa il contenuto della grid principale
Colonna | Dato
 | Un progressivo. Sfondo verde = casistica positiva, arancione = previsione in corso, neutro = casistica negativa.
N° Estr | Il numero dell’estrazione
Data Estraz | La data dell’estrazione
R1 | La prima ruota
N1…N5 | I 5 estratti della prima ruota con evidenziati quelli considerati
R2 | La seconda ruota
N1…N5 | I 5 estratti della seconda ruota con evidenziati quelli considerati
E1..E4 | I 4 estratti da considerare
TS | Il triplo sommativo (somma dei 4 numeri) uno sfondo violetto indica che il triplo sommativo è uguale ad una delle somme (verticali, orizzontali, diagonali). Questa caratteristica è solo segnalata in quanto in alcune metodologie previsionali viene presa in considerazione.
A1 | L’ambata di origine (la somma dei 3 numeri con identica caratteristica di ricavo)
A2 | L’ambata calcolata in base al parametro corrispondente selezionato
L1…L7 | I numeri della lunghetta
Col | Colpo di sfaldamento
Amb | Ambata
Ruote | La o le ruote di sfaldamento dell’ambata
Lunghetta | I numeri sfaldati della lunghetta
Ruote | Le ruote di sfaldamento della lunghetta

Questa parte riporta le somme e le distanze relative ad una determinata estrazione selezionata cliccando in una cella della tabella principale. È una situazione tipica della quadratura.

E1 e E2 sono gli elementi rilevati nella prima ruota
E3 e E4 sono gli elementi rilevati nella seconda ruota

Nell’esempio su sfondo giallo:

85 e 32 sono le somme orizzontali (45+40 e 47+75)
2 e 25 le somme verticali (45+47 e 40+75)
30 e 87 le somme diagonali …

Su sfondo verde:

5 e 28 le distanze orizzontali …
2 e 35 le distanze verticali …
30 e 7 le distanze diagonali …

Il numero al centro su sfondo blu è la somma dei 4 elementi.

In basso a destra è presente una piccola grid che riporta i consuntivi statistici

NCA = Numero casistiche elaborate; Pos = Casistiche con esito positivo, Neg = Casistiche negative, InG = casi in gioco

Colonna 1 = Numero ambate, colonne 2, 3, 4, 5 rispettivamente ambi, terni, quaterne e cinquine nella lunghetta impostata.

NB: un click col mouse sulla scritta Riepilogo statistico

apre una videata dove sono elencati gli sfaldamenti per colpo di gioco e sorte realizzata.

La colonna 1 è sempre riferita all’ambata, dalla colonna 2 alla 5 lo sfaldamento è riferito alla sorte (2, 3, 4, 5) rispetto al quantitativo di numeri della lunghetta.

Nella parte destra centralmente abbiamo un tabulatore con tre schede:

Iniziamo dalla 2° (Estrazione.)

Qui possiamo visualizzare l’estrazione completa relativa ad una riga selezionata dalla tabella principale.

Se si clicca in una cella compresa dalla prima colonna, N° Estr. sino alla colonna E4 viene visualizzata l’estrazione di ricavo come nell’immagine che segue. Sono evidenziati gli estratti coinvolti.

Nel 1° tabulatore (Correttori) possiamo effettuare degli aggiustamenti alle impostazioni per cercare di migliorare l’efficienza delle previsioni

Una avvertenza: Durante l'elaborazione delle due analisi descritte di seguito evitate di compiere altre azioni e attendere la fine dell'elaborazioni. (altrimenti potrebbero capitare blocchi del programma)

Il pulsante AMBATA + FISSO proverà tutte le combinazioni possibili tra questi 2 parametri ed i riscontri sono presentati nella grid dove in ordine decrescente troveremo elencati sia la modifica da selezionare all’ambata originaria ed anche il fisso da aggiungervi. Un doppio clic su una riga copierà questi valori nelle rispettive liste e poi premendo il comando PREVISIONI potremo verificarne i risultati che nell’esempio sono i seguenti.

Possiamo ancora provare il comando AMBATA + LUNGHETTA che verificherà tutte le possibili combinazione tra le modalità di ricavo dell’ambata con il passo della lunghetta. In questo caso ecco il risultato

Con la relativa statistica riepilogativa dopo l’utilizzo del comando PREVISIONI

Non ho previsto la verifica contemporanea di tipologia di ambata, fisso e passo della lunghetta in quanto l’elaborazione avrebbe richiesto tempi piuttosto lunghi.

La terza scheda (Database) consente di memorizzare le impostazioni per una determinata ricerca, così da poter essere richiamate in seguito.

Per salvare una configurazione immettere una descrizione nella casella Denominazione configurazione e poi utilizzare il pulsantino con il dischetto.

Per visionare l’elenco delle configurazioni memorizzate premere il pulsantino con raffigurata una cartella con freccetta verde.

Per cancellare una configurazione, selezionarla e usare il pulsantino con la crocetta rossa,

Facendo doppio click su una riga la configurazione corrispondente viene caricata adeguando tutte le impostazioni memorizzate.

Il check Ricava base dati, se abilitato eseguirà la ricerca delle estrazioni compatibili con le nuove impostazioni (come premere il comando RICAVA BASE DATI).

Il check Previsioni eseguirà immediatamente la ricerca delle previsioni (come premere il comando PREVISIONI)

Il check Adegua fine archivio e estraz. riferimento, se spuntato, consente di adeguare automaticamente la differenza esistente tra ultima estrazione in archivio ed estrazione di riferimento utilizzata in fase di salvataggio delle configurazioni con la nuova situazione dell’archivio aggiornato.

Esempio:
Configurazione salvata:

fine dell’archivio = estrazione n° 6887
estrazione di riferimento = 6883

Aggiornando l’archivio l’ultima estrazione diventa 6890

In questo caso col check menzionato spuntato caricando la configurazione precedentemente salvata avremo impostati questi nuovi valori:

fine dell’archivio = estrazione n° 6890
estrazione di riferimento = 6886

Tenete conto che in base alle impostazioni dei parametri configurabili è normale avere molte casistiche riferibili a poche estrazioni.

Si ottengono casistiche riferibili ad un maggior spazio temporale utilizzando ad esempio:

una determinata estrazione mensile come ricavo delle casistiche

poche ruote (o solo 2) considerate

pochi valori riferibili alle decine, cadenze, figure utilizzate come caratteristica esistente i 3 estratti dei 4 previsti

numeri abilitati

somme abilitate…

Infine nell’ultima scheda (In corso) sono riepilogate, se ce ne sono, le previsioni in corso.

Sono presenti i pulsantini per l’eventuale stampa della tabellina e la sua copia negli appunti.

Per ogni previsione in corso è riportata l’ambata, la lunghetta, il colpo di gioco / rispetto al totale dei colpi previsti.

Poi scorrendo è anche presente la data di ricavo della previsione e il relativo numero dell’estrazione.

Sono presenti i pulsantini per l’eventuale stampa della tabellina e la sua copia negli appunti.

Qui la copia della tabellina in esempio..
Amb | Lunghetta | Ruote | Colpo | Data Ricavo | N° Estr
39 | 39 48 57 66 75 | FI-TO | 1/12 | 03/05/2024 | 6886
42 | 42 51 60 69 78 | BA-VE | 2/12 | 02/05/2024 | 6885
42 | 42 51 60 69 78 | BA-RO | 2/12 | 02/05/2024 | 6885
34 | 34 43 52 61 70 | BA-VE | 2/12 | 02/05/2024 | 6885
41 | 41 50 59 68 77 | NA-VE | 2/12 | 02/05/2024 | 6885
44 | 44 53 62 71 80 | BA-NZ | 3/12 | 30/04/2024 | 6884
44 | 44 53 62 71 80 | FI-NA | 3/12 | 30/04/2024 | 6884
38 | 38 47 56 65 74 | FI-NZ | 3/12 | 30/04/2024 | 6884
47 | 47 56 65 74 83 | NA-NZ | 3/12 | 30/04/2024 | 6884
42 | 42 51 60 69 78 | CA-MI | 4/12 | 29/04/2024 | 6883


Riscontri esiti completo

Le previsioni ricavabili dal modulo principale sono considerate sfaldate al primo esito realizzato.

Sicuramente effettuando la verifica per la sola ambata o per sole sorti superiori riferibili ai numeri della lunghetta noterete delle discrepanze sul colpo di sfaldamento di una identica casistica (magari ad uno sfaldamento di ambata al 2° colpo potrebbe corrispondere uno sfaldamento di ambo al 3° colpo. Invece effettuando la verifica con entrambi le sorti selezionate fa sempre fede il primo esito realizzato e l’elaborazione si interrompe senza considerare i colpi successivi.

In questo modulo viene visualizzata l’evoluzione degli sfaldamenti considerando l’intero periodo di verifica (max 20 colpi)

Praticamente la tabella riporta i dati sino all’elenco della lunghetta (come nella tabella principale) poi sono elencati per ogni ruota i colpi di gioco previsti (dal primo colpo sino ventesimo). Per ogni colpo di gioco sono riportate due colonne; una di colore giallo (relativa alla prima ruota) e l’altra di colore verde (per la seconda ruota). Nelle celle di queste colonne, se si è verificato sfaldamento possono essere riportate sino a due cifre. 1 si riferisce all’esito dell’ambata, un valore da 2 a 5 significa che si è sfaldata la lunghetta e 2 sta per ambo, 3 per terno, 4 per quaterna, 5 per la cinquina. Naturalmente questi valori sono riferibili alla quantità di numeri che compongono la lunghetta. Supponendo che la lunghetta sia formata da 7 numeri, se in una cella è presente il valore 12 si deve leggere così: esito dell’ambata (la cifra 1) e di un ambo in settina (la cifra 2).

In alto nella videata sono riepilogati gli esiti delle ambate e delle sorti derivate dalla lunghetta.

Se vogliamo conoscere i numeri sortiti (da notare che l’ambata è rilevabile dalla colonna A2 della tabella) facendo doppio clic sulla cella valorizzata appare piccolo riepilogo dei numeri sortiti nell’estrazione riferita al colpo di sfaldamento.

Nel riquadro visualizzato sono evidenziati i numeri sortiti in cui sicuramente sono presenti i numeri che hanno dato esito. Sono riportati anche numeri singoli della lunghetta che non hanno prodotto esiti.

Questo è il riquadro che viene proposto con il doppio click su una cella valorizzata della tabella riepilogativa

Ho cliccato sulla cella di riga 19 (quella evidenziata corrispondente al 7° colpo di gioco).

Viene aperto l’elenco dei numeri sortiti nell’estrazione corrispondente al 7° colpo di gioco e troviamo evidenziati i numeri sortiti. Nel caso ad esempio l’ambo in settina 79-52 nella ruota di Cagliari, l’ambata 52 sia su Cagliari che a Palermo. Vi ricordo che l’ambata è riportata nella colonna della tabella principale evidenziata di verde e titolata A2.

Nel mini elenco, in alto a destra, è riportata la data dell'estrazione e il suo numero indice.

In basso è riportato il progressivo mensile (PM) e quello annuale (PA)


Selezione dell'archivio delle estrazioni
L’archivio delle estrazioni risiede in un database Access con estensione Mdb.

Potrete disporre di altri miei software che possono utilizzare un unico archivio per cui, al primo utilizzo del software viene richiesto a quale archivio fare riferimento per poterne aggiornare uno solamente che poi sarà utilizzato anche da altri software.

Per selezionare l’archivio, quando comparirà questa videata…

Premere il pulsante SELEZIONE ARCHIVIO….

Ricercare l’archivio da utilizzare (viene sempre proposto quello contenuto nella cartella di installazione del software)

Selezionare il file, in questo caso DbTriplaSommaTop, e premere il pulsante Apri.

L’archivio è selezionato e la videata sarà chiusa.

Nella precedente videata viene aggiornata la posizione dell’archivio (sotto la scritta Percorso archivio)

Attenzione: al primo lancio del programma il percorso sarà sicuramente errato in quanto è quello riferito al mio PC.
Quindi se procederete senza la necessaria configurazione il programma terminerà in quanto il file di riferimento non sarà trovato. Normalmente il programma apre in automatico la finestra per la selezione dell’archivio.

Una volta configurato l’archivio premere il pulsante PROCEDI per visualizzare la videata contenitore del software.

Avvertenza:

In alcuni casi il database fornito con il programma potrebbe essere replicato nella cartella Virtualstore del PC per cui il percorso potrebbe essere ad esempio:

C:\Users\User\AppData\Local|VirtualStore\Program Files (x86)\TriploSommativo

Dove User potrebbe essere sostituito dal vostro account .

La cartella AppData potrebbe essere nascosta per cui per visualizzarla dovete modificare le proprietà di visualizzazione.


Gestione estrazioni

Il modulo consente di effettuare operazioni di manutenzione ed aggiornamenti dell’archivio.

Nel tabulatore Gestione estrazioni possiamo inserire nuove estrazioni, modificare quelle presenti ed eventualmente cancellarle.

L’archivio viene automaticamente ordinato in base alla data delle estrazioni per cui è possibile inserire estrazioni come desiderate anche se consiglio caldamente di rispettare l’ordine cronologico per comodità.

Nella parte alta a sinistra è presente una barra di navigazione che permette di spostarsi comodamente nell’archivio.
Sono presenti 3 pulsantini che consentono di selezionare una precisa estrazioni inserendo il numero indice della stessa oppure la data.

A fianco della barra è indicato sia il numero indice dell’estrazione e la relativa data (dell’estrazione visualizzata). Il pulsantino con la freccetta nera rivolta verso il basso consente di rendere la data visualizzata utilizzabile nel calendario riportato in basso.

La casella Mensile riporta l’indice mensile dell’estrazione. La casella Annuale riporta l’indice annuale.

La grid posizionata alla destra della videata riporta tutte le estrazioni di un determinato anno selezionabile da una apposita lista. La grid è organizzata per mesi e giorni di ciascun mese

Nelle celle corrispondenti al mese ed al giorno di quel mese è presente un numero o una sigla che si riferisce al giorno della settimana relativo all’estrazione. Sta a voi decidere se utilizzare il numero o la sigla per l’identificazione del giorno.
Utilizzando il Check Sigla giorno settimana potete effettuare questa scelta.

Per i numeri 1 rappresenta la domenica, 2 lunedì….. sino al 7 che corrisponde al sabato.

Relativamente alle sigle queste non sono altro che l’iniziale del nome del giorno. Unica segnalazione per il Martedì dove ho utilizzato la M maiuscola, mentre per il mercoledì ho usato la m minuscola.

Sotto la grid è riportata una breve legenda su come interpretare numeri o sigle.

Con un doppio clic del mouse l’estrazione corrispondente viene caricata e visualizzata.

Il pulsantino subito sopra al calendario consente di impostare la data odierna.

Descrizione della funzionalità del pulsanti per l’aggiornamento delle estrazioni:

COLLEGA AL SITO: Consente di aprire una connessione internet direttamente al sito predefinito per l’aggiornamento

Quello visualizzato è il sito delle dogane dove sono riportati i dati ufficiali delle estrazioni.

Per selezionare le estrazioni cliccare col mouse subito prima della B della ruota di Bari, tenendo premuto il pulsante sinistro del mouse selezionare gli estratti sino all’ultimo numero della ruota Nazionale. Tutta l’area selezionata risulterà evidenziata. Per copiare il contenuto negli appunti utilizzare la combinazioni di tasti Control + C oppure tasto destro del mouse all’interno dell’area evidenziata e selezionare la voce Copia. L’immagine riporta quest’ultima modalità

AZZERA GRID: cancella il contenuto della grid (non è indispensabile questa operazione ma è consigliata)

INCOLLA ESTRAZIONE: incolla il contenuto degli appunti (gli estratti) nella grid. È sempre opportuno controllare il primo di Bari e l’ultimo della ruota nazionale per sicurezza.

SALVA ESTRAZIONE: viene salvata l’estrazione con i dati impostati (estratti e data di riferimento)
Prima di procedere al salvataggio ricordatevi di avere selezionato la data correttamente dall’apposito calendario.
Viene sempre visualizzato un messaggio di conferma con riportata la data impostata. Controllate sempre che questa sia quella giusta prima della definitiva conferma.
Non dovete essere precipitosi nel dare conferma al messaggio, l’operazione di controllo richiede pochissimi secondi.

Ricapitolando, per salvare una nuova estrazione…

Cancellare il contenuto della grid (pulsante AZZERA GRID)

Collegarsi al sito predefinito per visualizzare l’estrazione (pulsante COLLEGA AL SITO)

Copiare gli estratti nella modalità precedentemente descritta.

Incollare gli estratti (pulsante INCOLLA ESTRAZIONE)

Impostare subito la data di riferimento (Tramite il calendario… controllare che la data venga riportata anche nella casella Data selezionata)

Salvataggio dei dati (pulsante SALVA ESTRAZIONE)

Restano ancora un paio di comandi che sono:

MODIFICA ESTRAZIONE: Modifica l’estrazione visualizzata

CANCELLA ESTRAZIONE: Cancella l’estrazione visualizzata


Elenco estrazioni
Tabulatore Elenco estrazioni

Qui è riportato l’archivio completo delle estrazioni utile per pura consultazione senza particolari funzionalità

Selezionando una qualsiasi riga questa viene evidenziata ed utilizzando il pulsantino con raffigurata una manina che impugna un documento potremo caricare quell’estrazione nel tabulatore Gestione estrazioni.

I pulsantini in alto a destra consentono di posizionarsi a inizio o fine archivio.


Salvataggi
Tabulatore Salvataggi

Qui sono presenti funzionalità che sono utili a chi già possiede altri miei software.

Il formato degli archivi che ho utilizzato in passato è diverso da quello adottato in questo nuovo programma.
Allora non era ancora stata introdotta la ruota nazionale e questa di conseguenza questa non viene gestita nei vecchi archivi.

Il primo pulsante SALVA IN FORMATO LOTTONEW 3 (Dati.iii) consente di salvare i dati in questo formato.
A secondo dei miei programmi in vostro possesso il file in questo formato sarà presente in una o più cartelle dove sono installati i programmi.
In quasi tutti i miei software era possibile selezionare un archivio di riferimento ‘comune‘ per evitare di dovere aggiornare più archivi. In questi casi basterà impostare la cartella predefinita nei vecchi software.

La posizione del file Dati.iii, ad esempio, è sempre riportata in una apposita casella
Nella videata seguente … Archivio estrazioni: C:\LNEW3\Dati.iii

Quando salverete i dati in questo formato dovete fare riferimento alla cartella visualizzata

A fianco del pulsante SALVA IN FORMATO LOTTONEW 3 (Dati.iii) è riportato il percorso predefinito per questo formato. Se non corrisponde a quello presente sul vostro PC allora basterà ricercarlo una prima volta tramite questa videata che appare lanciando uno dei miei precedenti software. Qui sotto un esempio dove il percorso del file dati.iii è riportato nella casella Archivio estrazioni.

Una volta identificata la cartella dove presente l’archivio dovete sempre selezionarlo (potreste avere assegnato un nome diverso da Dati.iii, magari per una copia di sicurezza).

Dopo la selezione utilizzando il comando SALVA il file sarà salvato e il percorso relativo del file viene riportato nella casella con sfondo giallino.

Per renderlo effettivamente quello predefinito (per cui ai successivi utilizzi di questa funzionalità verrà sempre visualizzata la relativa cartella) utilizzare il pulsantino RENDE PREDEFINITA.

Il pulsante SALVA IN FORMATO LOTTOSPRINT procede al salvataggio automatico del file esclusivamente nella cartella:

C:\Lnew3\

Il file è denominato Dati32.iii.
Solo pochissime persone sono in possesso dei miei software che utilizzavano questo formato (peraltro un semplice file testuale) ma che veniva utilizzato da un compilatore, a quei tempi, estremamente performante.

Se non avete questi programmi questa funzionalità non è utilizzabile.

Infine è presente il pulsante SALVA NAZIONALE IN FORMATO TESTO, anche questo utilizzabile da coloro che sono in possesso di alcuni miei software dedicati.

Una nota particolare riguardo l’utilizzo del Check Aggiunge estrazione del 10-06-1961…

Relativamente ai formati Lottonew 3 e Lottosprint l’archivio che ho utilizzato come riferimento iniziale dei miei programmi conteneva i riferimenti a quell’estrazione (non avvenuta) impostati con valori “99” o “00”.

Chi aveva creato quell’archivio (che avevo scaricato da Internet) aveva l’estrazione presente ma naturalmente non utilizzabile in quanto di fatto non avvenuta.

Il problema è che in alcuni miei software i riferimenti delle estrazioni (ad esempio in Methodus 2.0) sono riferiti all’archivio con presente quell’estrazione per cui se questa non è presente tutti i relativi riferimenti sarebbero errati.

Quindi, in termini pratici, è opportuno lasciare questo check selezionato per evitare i problemi descritti.
Naturalmente se qualcuno ha provveduto ad eliminare preventivamente quell’estrazione prima di effettuare le procedure che facevano riferimento agli indici delle estrazioni allora il check deve essere deselezionato.
Infine nella casella Indirizzo internet è riportato l’indirizzo del sito dove prelevare le estrazioni in modalità manuale.

Se desiderate utilizzarne un altro a vostra discrezione basterà accedervi e copiare il relativo indirizzo negli appunti.
A seguire incollare il contenuto degli appunti nella casella tramite il pulsantino all’estrema destra sopra alla casella.

Per renderlo predefinito utilizzare il pulsante RENDE PREDEFINITO.

Un doppio clic all’interno della casella cancella il contenuto.

Per incollare il contenuto degli appunti potete anche selezionare la casella col doppio clic e utilizzare la combinazione dei tasti Control + V.


Aggiornamenti
Tabulatore Aggiornamenti

In questo riquadro è possibile effettuare l’aggiornamento automatico delle estrazioni da Internet.

Per prima cosa si deve utilizzare il comando CONTROLLO AGGIORNAMENTI per verificare la disponibilità di nuove estrazioni. Se tutto va per il verso giusto si presenta una situazione di questo tipo dove lo sfondo verde nelle colonne delle ruote identifica i dati corretti. Lo sfondo bianco identifica errori in quella ruota e se abbinato allo sfondo arancione nella colonna della data viene identificata una estrazione da inserire

In questo caso c’è una estrazione da inserire in archivio (quella del 10/06/2023)
Inoltre è presente un errore nell’estrazione del 6/6/2023 sulla ruota di Bari.

Il check Corregge estrazioni errate, se spuntato, abilita la modifica delle estrazioni con errori.

A questo punto si utilizza il pulsante AGGIORNAMENTO per poter inserire le nuove estrazioni nell’archivio del programma.

Al termine dell’aggiornamento apparirà un messaggio…

A questo punto l’archivio sarà aggiornato e la videata si posizionerà sul tabulatore Gestione estrazioni.

Tenete in considerazione che la procedura di aggiornamento automatico delle estrazioni non è garantita nel tempo per cui quando non dovesse essere più disponibile dovete provvedere all’aggiornamento in modalità manuale precedentemente descritta.

Gli aggiornamenti di norma saranno disponibili il giorno successivo all’ultima estrazione effettuata ma potranno esserci periodi in cui la disponibilità potrà richiedere diversi giorni.

In ogni caso avete la possibilità, con poca fatica, di effettuare gli aggiornamenti manualmente.

Il pulsante AGGIORNA DA FILE consente di selezionare un file compatibile generato magari da un altro utente o distribuito dal programmatore per procedere all’aggiornamento senza utilizzare internet.

Una volta selezionato un file valido la procedura di aggiornamento, una volta elencate le estrazioni presenti nel file, è la stessa vista precedentemente.


Come utilizzare un altro archivio
 Previous Top

COME SELEZIONARE UN ARCHIVIO DELLE ESTRAZIONI DIVERSO DA QUELLO INSTALLATO CON IL PROGRAMMA

Se disponete di miei programmi con relativo archivio delle estrazioni conviene utilizzare un unico archivio per evitare di aggiornare più archivi.

Questo è un esempio di come eseguire il procedimento.

Il programma installato è Tripla Somma Top
(l’archivio delle estrazioni fornito è denominato DbTriplSommaTop.mdb)
--------------------------------------------------------------------------------------------------------------------------------------------
L’archivio che andremo a selezionare è quello installato con il programma Supernumber
Tale archivio è denominato DbSupernumber.mdb e al termine della procedura sarà quello utilizzato da entrambi i programmi.

Lanciando Tripla Somma Top appare questa videata…

Premere il comando SELEZIONE ARCHIVIO… Appare questa schermata

Riapparirà la schermata iniziale dove potrete constatare che il percorso dell’archivio è stato adeguato alla nuova selezione

premere il pulsante PROCEDI.

Probabilmente apparirà questo avviso

Ora dovrete terminare il programma premendo il pulsante FINE e riavviarlo.

Da questo momento basterà aggiornate un unico archivio che sarà utilizzato da entrambi i software.

Quando disporrete di altri miei programmi basterà seguire questa stessa procedura per utilizzare lo stesso archivio.

Una nota da considerare.

Se utilizzate contemporaneamente miei software che utilizzano lo stesso archivio conviene chiudere i programmi che non sono utilizzati per l’aggiornamento e poi rilanciarli dopo avere effettuato l’aggiornamento dell’archivio.

Questo perché l’archivio viene caricato nei programmi al lancio dei medesimi.